I have performed a fresh installation of conda in preparation for the new 2018 version of the api however i have been having some trouble with installing the conda packages.

Where previously there were tar files within the miniconda/pkgs directory there are now just directories, as such i am unable to run the 'conda install' command. 

Attempting the command on the directory (since there is no tar file) just leads to the below output:

conda install csd-python-api-1.5.1-mac-64-py2.7-conda

Solving environment: failed


PackagesNotFoundError: The following packages are not available from current channels:


  - csd-python-api-1.5.1-mac-64-py2.7-conda


Current channels:


  - https://repo.continuum.io/pkgs/main/osx-64

  - https://repo.continuum.io/pkgs/main/noarch

  - https://repo.continuum.io/pkgs/free/osx-64

  - https://repo.continuum.io/pkgs/free/noarch

  - https://repo.continuum.io/pkgs/r/osx-64

  - https://repo.continuum.io/pkgs/r/noarch

  - https://repo.continuum.io/pkgs/pro/osx-64

  - https://repo.continuum.io/pkgs/pro/noarch


Is the lack of tar files an issue with the latest OSx release or am I missing something that has been changed in the process?




I have resolved this issue, it was an issue with env variables.






Hi Jacob,

I have tried to install CSD python API using conda on windows and encountered some problems. The output is almost the same as yours. Would you mind to tell me how you've solved this problem? Thank you very much.

Best wishes,


Hi Jacob,

If you report the errors here, we can see whether there is a solution.


I'm working on a mac, and when I attempt to finish setting up the Python 3 API by running the command conda install -c <path to>ccdc_conda_channel/ csd-python-api I get exactly the same error:

PackagesNotFoundError: The following packages are not available from current channels:

- csd-python-api

Current channels:

- file://<path to> ccdc_conda_channel/osx-64
- file://<path to> ccdc_conda_channel/noarch
- https://repo.anaconda.com/pkgs/main/osx-64
- https://repo.anaconda.com/pkgs/main/noarch
- https://repo.anaconda.com/pkgs/free/osx-64
- https://repo.anaconda.com/pkgs/free/noarch
- https://repo.anaconda.com/pkgs/r/osx-64
- https://repo.anaconda.com/pkgs/r/noarch

I'm working with a completely fresh installation. Is there anything I can do to resolve this issue?

You must be signed in to post in this forum.