Hi,

 

I'm trying to install rdkit (I have tried both through conda and pip) and it fails with the following error message:

 

PackagesNotFoundError: The following packages are not available from current channels:

 

  - csd-python-api-1.5.1-mac-64

 

Current channels:

 

  - https://repo.anaconda.com/pkgs/main/osx-64

  - https://repo.anaconda.com/pkgs/main/noarch

  - https://repo.anaconda.com/pkgs/free/osx-64

  - https://repo.anaconda.com/pkgs/free/noarch

  - https://repo.anaconda.com/pkgs/r/osx-64

  - https://repo.anaconda.com/pkgs/r/noarch

  - https://repo.anaconda.com/pkgs/pro/osx-64

  - https://repo.anaconda.com/pkgs/pro/noarch

  - https://conda.anaconda.org/conda-forge/osx-64

  - https://conda.anaconda.org/conda-forge/noarch

 

Am I missing something? I need rdkit and the csd python api working on the same environment, so any help would be appreciated..

 

Thanks

Puck 

Hi Puck,

 

We have seen various problems when rdkit and the CSD Python API are used together due to mutually incompatible dependencies. Have you tried following the instructions from our API troubleshooting instructions?  These require that you have already downloaded the desired API conda package as it is not present on any public package repository.

 

I hope that helps,

Stewart.

Hi, 

 

I just tried this and now it seems to install the rdkit package but when I try to import it in ipython it says "ImportError: No module named rdkit". The ccdc package works fine.

Any ideas?

Puck 

Hi Puck,

 

That is curious.  That error is what I'd expect to see if the rdkit python module wasn't installed.  If you use "conda list" is the appropriate environment, do you see rdkit in the table?

 

Stewart.

Hi Stewart,

 

Sorry, I temporarily gave up on this. Yes, it's listed in the installed environments so it's definitely installed. Before the ccdc package is installed in the environment it imports fine, but once the ccdc package is installed in the same environment it won't import anymore. I've tried both in ipython and from a python file. I've just been resorting to using rdkit and ccdc in separate environments but it would make my life a lot easier if I could use them in the same environment! 

Puck 

Hi Puck,

I would like to understand what the underlying problem is, but I am currently unable to reproduce it.  Please would you email support@ccdc.cam.ac.uk with details of the various software versions you are using - e.g., your operating system version your ipython/jupyter version. Please also let us know what steps you are using for the installation, and whether you are trying the miniconda environment shipped with the CSD system, or you own miniconda/anaconda.

Thanks in advance,

Stewart.

You must be signed in to post in this forum.